DNN Disqus Module Setup (for DNN Blog 5.0.0)

Feb 17, 2013 at 10:30 PM
I’m trying to setup DNN Disqus Module 2.0.0 for DNN Blog 5.0.0 (DNN Community Edition 07.00.03). I registered the website (Site URL, Site Name, and Site Shortname from https://disqus.com/admin/signup/). Then, I registered a new application (Label, Description, Website, and Authentication from http://disqus.com/api/applications/). So, I have the Shortname (from Disqus Step 1: Website Registration) and a Secret Key (from Disqus Step 2: Application Registration).

I always receive the error: "You must be authenticated to perform this action"
This error persists regardless, if the post/comment is coming from a DNN logged in portal user o not.

Of course, if I logged in the Disqus Module with my Disqus Credentials, then it goes through...

Below are details of how I set the Disqus Account/API and Disqus Module. Hopefuly, I described it enough...


In Disqus 2012 I can see the following on General Admin Settings:
Shortname: <myShortname>
Werbsite Name: <myWebsiteName>
Website URL: <myWebsiteURL>
Guest Commenting: Allow guests to comment. [CHECKED]
Pre-moderation: NONE – Comments don’t need to be approved before they are published.

Under API Resources Application Details Settings:
Website: <myWebsiteURL>
API Key: <some_long_API_Key_string>
API Secret: <some_long_API_Secret_Key_string>
Authorize URL: https://disqus.com/api/oauth/2.0/authorize/
Access Token URL: https://disqus.com/api/oauth/2.0/access_token/
Access Token: <some_long_hex_string>
Permissions: Read, Write

In Disqus Module > Edit Disqus Settings:
Disqus View: Comments
Attach Comments To Module: Blog Module
Disqus Application Short Name: <myShortname>
Disqus Application Secret Key: < some_long_API_Secret_Key_string >
Require Login for Comments?: UNCHECKED
Apr 2, 2013 at 8:31 PM
Finally I had a chance to sit down with this again. And finally, it is working!
Funny thing is that I did not change any procedure... I simply deleted in DISQUS the Registered Application under http://disqus.com/api/applications/ and deleted the website I registered in Step #1 where one puts in the shortname. After that, I simply went through the process again and used the following to feed the DNN Disqus Module.

Disqus Application Short Name = DISQUS Shortname (found in General Admin Settings)
Disqus Application Secret Key = DISQUS API Secret (found under API Resources Application Details Settings)

NO clue why it did not work the first time...
Sep 6, 2014 at 6:02 PM
The same behaviour, and it is a worst case, the same configuration run on a test domain but in the final domain is unable to accept the Disqus API secret key and application name. Once entered the module ask again for the same information

Any ideas?

DNN 7.3.2 / IIS8.5 / ASP.NET4.5 / MSSQLS2012 Express / MSS2012x64


Sep 7, 2014 at 9:13 AM
OMG, trying to reinstall the module, it has crashed my website. Being unable to find the fix for the error in short time I decided to restore my daily backup although a whole day of hard work is finally lost. Well, I decided to uninstall the module and I tested a different approach for solving my needs. The main thing is to tie the disqus comments to a module, so wherever the modules is moved, the disqus comments went with it. So, I got the disqus Universal Code and I inserted it directly in the footer section of each module that I need to be commented, and voilà, it runs perfectly without the need of any extra module. More over, I can define more things using the JS parameters of the Disqus Universal Code.

Best regards